PDA

View Full Version : Problems I've not yet seen answered.



thechuff
05-27-2009, 04:25 PM
Before I describe what's going on, I just want to say

Yes, yes, yes

yes. I have read the thread that everyone likes to throw at problems.
Unfortunately my problems have nothing to do with apostrophes or special characters in links, nor with unfinished link names (sherlock... 'stheme.mp3).

No.

Now. Here's the deal.

#1. The pages for sheet music do not load at all.
This is the text that loads for every single one:


Warning: include() [function.include]: URL file-access is disabled in the server configuration in /home/gh/public_html/sheet-music on line 16

Warning: include(http://gh.ffshrine.org/sheet-music.php?d=&f=) [function.include]: failed to open stream: no suitable wrapper could be found in /home/gh/public_html/sheet-music on line 16

Warning: include() [function.include]: Failed opening 'http://gh.ffshrine.org/sheet-music.php?d=&f=' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/gh/public_html/sheet-music on line 16

#2. None of the MP3's are sound files, and are all 38 bytes.
And for every single MP3 file, the downloads appear to work, but the files are all empty, and are all exactly the same size (38.0 bytes).

#3. MIDIs don't work either (I don't want any, I just checked...)
This is the text for any MIDI page.



Warning: include() [function.include]: URL file-access is disabled in the server configuration in /home/gh/public_html/midis on line 17

Warning: include(http://gh.ffshrine.org/midis.php?p=&g=&s=) [function.include]: failed to open stream: no suitable wrapper could be found in /home/gh/public_html/midis on line 17

Warning: include() [function.include]: Failed opening 'http://gh.ffshrine.org/midis.php?p=&g=&s=' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/gh/public_html/midis on line 17


Please help.

Penguin
05-28-2009, 12:36 AM
I am working on this as we speak.

hiccupz
06-27-2009, 11:32 PM
if you were working on it "as we speak" ( which was about a month ago ) then why do these problems still exist? Q_Q

Neg
06-27-2009, 11:48 PM
Because he was lying.

I've been on vacation. I'm sorry for the inconvenience.

ultddave
06-29-2009, 02:30 PM
This is 1 of the problems I think :).

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/gh/public_html/utils/mangacache.php on line 2

You probably tried the code on a local server but forgot to change host,login and password to the one from the mysql on the server.

I'd recommend to use an if-test like this:



if (!mysql_select_db($database,$db)) {
echo "Database connection failed.<br/>";
}
else
{
// content
}

for some error handling ;).

Greetz

hiccupz
06-29-2009, 06:34 PM
Now to hope someone sees this. :(

TK
06-29-2009, 11:15 PM
Guys, I know we are ridiculous in GD, but as I've asked before, please don't shit up threads in this forum. You can be a smartass to people in GD but this forum is supposed to actually accomplish something.

I can't help with the problem but hopefully Sarah knows about it and is working on it. You could try sending her a PM.

hiccupz
07-02-2009, 05:30 PM
Tk;
I'm not trying to be a smartass. I'm bemoaning the death of a great section of this site that can be brought back, given some time is spent working on it. I looked for about 15 minutes on how to send a PM on stupid VBulletin but I can't find a way to message Sarah.
I'm sorry if I did come across as a smartass, because I am only trying to help accomplish something.

Neg
07-02-2009, 05:39 PM
He was talking to me and Tangerine, man. Not you.

Red Arremer
07-02-2009, 06:25 PM
Galbadia Hotel's servers in general are kinda in trouble at the moment. All you can do is wait and have patience. I think Sarah is very well aware of the problem, just didn't get around fixing it (yet).

ultddave
07-03-2009, 06:31 AM
The server settings doesn't have allow_url_include set to "yes". So the website can't include files from another server using url. Most of the servers don't allow this option because it can be used by hackers. Hackers can force the site to include their script instead. = not good :P

Shared hostings have their php.ini file in the root/etc (this can be different for other hosts) and that file contains the settings, which affects all websites on the server. So if the settings are set to "yes" for allow_url_include, then all the websites will have a security risk.

If gh has their own servers, they can probably change the php.ini file. (takes about 2 minutes to change it via FTP). But it comes with the security risk mentioned above.

Solution 1: Place the website and files on 1 server. (Then use the fopen command)
Solution 2: Convince the host to enable the allow_url_include settings. (if you can't change the settings that is)
Solution 3: Change to a server which does allow "allow_url_include".

Solution 1 would be the best imo. (Don't forget to change the php code after placing both on 1 server.)

So it's not really something Sarah can "fix". Rather a difficult decision she (and the team probably) has to make.

If you need some help with the code, feel free to ask help.

Greetz,
Dave

Sorry for my bad english XD.